PHP is one of the most widely used coding languages. It is rather popular as it is free software, which you can use to create responsive sites like social networks, e-shops or online learning sites rather than static HTML sites. A PHP module must be enabled on the server where a PHP-powered website is hosted so that its PHP code can be ‘translated’. Since there are no license charges for this sort of module and the language offers infinite options for the Internet apps that you set up, there are hundreds of millions of PHP-driven sites. On top of that, there are an immense number of open-source PHP scripts, which you can use for your websites without having to possess any programming expertise. Considering the fact that there’re several PHP versions, you should make sure that the same version that you used whilst creating your site is activated on the web server too.

PHP 4, PHP 5 and PHP 7 Support in Cloud Hosting

With our Linux cloud hosting, you will be able to select which PHP version will be active for your shared account, as we offer support for multiple versions. With just one mouse click, you will be able to switch between PHP 4, 5, 7 and every time a new version is launched in the future, we’ll add it to the Hepsia hosting Control Panel without removing the previous ones. In this way, you’ll be able to host all the sites that you’ve built throughout the years. In contrast to lots of other web hosts, we will not force you to update such sites, because a script may be outdated, but this doesn’t automatically mean that it is vulnerable since you may have edited its code to fill safety loopholes. For your convenience, you’ll even be able to set a different PHP version for each single site that you host in your account.

PHP 4, PHP 5 and PHP 7 Support in Semi-dedicated Hosting

In case you’ve got a website created with an earlier version of PHP and you’ve put time and effort into setting it up, filling security gaps and publishing web page content, you will need to find a hosting service that can support it, since the majority of web hosting vendors these days offer only the most recently introduced version of PHP and remove the previous versions. We, however, have decided to allow you to select the exact version that your own sites require. Our Linux semi-dedicated hosting support PHP 4, PHP 5 and PHP 7, which implies that you will be able to run both older and newer scripts without losing any manual modifications or frittering away time striving to make your websites compatible with the web hosting platform. The current version can be changed from the Hepsia hosting Control Panel and such a change will apply to the whole semi-dedicated account, but you will also have the ability to specify a different version of PHP for each single website hosted in your account by using an .htaccess config file.